文言文编程已横空出世,象形甲骨文编程是胡说八道吗? - 考试试卷 - 甲骨文研究网 甲骨文密码字典 在线甲骨文字典研究 认路


百度 站内搜索

首页 > 正文

文言文编程已横空出世,象形甲骨文编程是胡说八道吗?
日期:2020-04-30   来源:甲骨文研究网   评论:0    点击:

摘要

(图片引用自《噫吁嚱!文言文亦能编程!此诚年度最骚语言也》)开发文言文编程语言的是正在读大四的HuangLingdong同学,用量子位的话来说

(图片引用自《噫吁嚱!文言文亦能编程!此诚年度最骚语言也》)

吾有系列则被用来做定义:

……

大意是说世间编程语言多如《天官》中的星宿、奇胜过《山海经》中的走兽,虽然仓颉造字惊天地、泣鬼神,造字已有几千年,但是却好像从来没有出现过文言文编程 语言,这实在是不应该啊,这实在不是中华文化的幸事啊,有鉴于此,我这个后生晚辈就产生了开发文言文编程语言的想法,并把这个作为了自己的一个志向。

据信六十多年前宗教家破解了《诗经》,创造了IBM 701,《诗经》的所有架构在1956年被成功应用于IBM305 RAMAC,为人类带来了信息工业革命,IBM也因此而辉煌,笑傲江湖数十年。可惜甲骨文在清朝时被雪藏,甲骨文视觉方程几乎失传,可喜的是如今已有年轻 人开发出文言文编程语言,甲骨文的象形本义也还原了一部分(参见《多功能汉字甲骨文破译字典》),距离破译甲骨文象形程序语言又前进了一步;正所谓长江后浪推前浪,希望年轻人多多潜心研究,破译古籍,让真正的中华文化重新发出璀璨的光芒,而你们也终将青史留名,泽被后人,万古流芳。

附:文言文编程的基本语法(节选):

Variables

wenyan

JavaScript

吾有一術。名之曰「吸星大法」。是術曰。⋯⋯是謂「吸星大法」之術也。

function f(){...}

吾有一術。名之曰「六脈神劍」。欲行是術。必先得六數。曰「甲」。曰「乙」。曰「丙」。曰「丁」。曰「戊」。曰「己」乃行是術曰。⋯⋯是謂「六脈神劍」之術也。

function f(a,b,c,d,e,f){...}

吾有一術。名之曰「翻倍」。欲行是術。必先得一數。曰「甲」。乃行是術曰。乘「甲」以二。名之曰「乙」。乃得「乙」。是謂「翻倍」之術也。

function double(a){var b = a * 2; return b;}

施「翻倍」於「大衍」。

double(dayan);

吾有一數。曰五。書之。

console.log(5);

Control

wenyan

JavaScript

吾有一物。名之曰「甲」。

var a = {};

吾有一物。名之曰「甲」。其物如是。物之「「乙」」者。數曰三。物之「「丙」」者。言曰「「丁」」。是謂「甲」之物也。

var a = {b:3, c:"d"}

Math

wenyan

JavaScript

吾有一列。名之曰「甲」。充「甲」以四。以二。

var a = []; a.push(4, 2);

銜「甲」以「乙」。以「丙」

a.concat(b).concat(c);

夫「甲」之一。

a[0]

夫「甲」之其餘。

a.slice(1);

夫「玫瑰」之「「名」」。

rose["name"]

夫「寶劍」之長。

sword.length;

Containers

 

 

 

https://github.com/LingDong-/wenyan-lang

线上IDE试玩:
http://wenyan-lang.lingdong.works/ide.html

<p style="margin: 0px; padding: 0px; max-width: 100%; clear: both; min-height: 1em; color: rgb(51, 51, 51); font-family: -apple-system-font, BlinkMacSystemFont, " helvetica="" neue",="" "pingfang="" sc",="" "hiragino="" sans="" gb",="" "microsoft="" yahei="" ui",="" yahei",="" arial,="" sans-serif;="" font-size:="" 17px;="" letter-spacing:="" 0.544px;="" text-align:="" justify;="" box-sizing:="" border-box="" !important;="" word-wrap:="" break-word="" !important;"="">个人主页:
https://lingdong.works/
----------
【甲骨密码公众号6本内部著作接受预订】
1●《新编甲骨文破译案例解析》提高逻辑推理、辩证思维、提升智力的独特思维训练方法教案
2●《多功能汉字甲骨文破译字典》大中小学考试、象形识字速记、古文破译通用字典
3●《汉字甲骨文象形速记手册》(一年级上下册合订本)幼儿园、小学快速识字读本,开发智力启迪智慧
4●《山海经传奇之决战昆仑》被遗忘的传说:女娲创世记,中国第一本把山海经神话故事科幻化的小说,也是传统文化、神话、科幻、系统化启蒙读本
5●《财神是怎样练成的》中国高考精英选拔内训读本,创新与批判性思维训练,重塑三观:人生观、世界观、金钱观
6●《金庸武侠人物姓名隐藏的命运密码》姓名吉凶、为什么甲骨文测字的准确度最高?
【见你所未见,闻你所未闻,"甲骨密码"微信公众号:jiagumima】

相关热词搜索:文言文编程 横空出世 象形 甲骨文编程 胡说八道

上一篇:今后全国高考语文的趋势及古文阅读可以轻松得分的方法
下一篇:最后一页

   作者/编辑:jiaguwen 收藏
Hot Tags:
  本网破译的所有甲骨文象形本义全部收录在《多功能汉字甲骨文破译字典》一书中,破解的古诗、竹简等古文作品收录在《新编甲骨文破译案例解析》一书中。
  因时间、精力有限,破译的甲骨文象形本义只有少数上传到网站上,对甲骨文感兴趣、想全面了解者可参阅本网所著的这一套甲骨文系列图书。

====================
甲骨文Oracle 金文Inscriptions on bronze 古代Ancient 游戏Game 性感Sexy 生育Birth 繁衍Reproduction 赚钱Make money 爱情Love 暴利Huge profits 篆文Zhuanwen 命名Named 财富Wealth 象形文字Glyph 算命Fortune-telling 吉凶Good and bad 记忆色彩Memory 方法Method
====================